WordPress

WordPress 2.1 MySQL gereksinimleri

16 Ocak
08:03 2007

Yakın zamanda wordpress 2.1 geliyor. Evet gözle görülebilir fazla değişiklik yok ama kodlama olarak bir takım değişiklikler söz konusu. Bunlardan biri de MySQL sürümleri desteği konusunda yaşanıyor. WordPress 2.0.x sürümleri Mysql 3.23.23 desteği kullanıcılara sağlıyor. Fakat yaratıcılar yeni sürümde MySQL 3.23.23 desteğini kaldıracaklarını bildirmişler ve kullanıcıları şimdiden konfigürasyonlarını yükseltmeleri gerektiğine işaret ediyorlar.

WordPress 2.1 MySQL Requirements başlığındaki haberde yer verilen açıklamaya göre önümüzdeki günlerde yayınlanacak wordpress 2.1 için MySQL 4.0 zorunlu koşulacak. Eklenti geliştiricilerin isteği ise en az 4.1 sürümünün desteklenmesi. Fakat birçok hosting firmasının 4.0 kullanmasından ötürü wordpress 2.1 sürümünde 4.0 tercih edilmiş. Fakat mySQL 4.1 zorunluluğu wordpress 2.2 sürümünde gerçekleşebilirmiş.

Peki daha yeni sürüm MySQL tercih edilmeli midir?
Evet kesinlikle yeni sürüm MySQL sunucuları tercih edilmelidir. Adı üstünde yeni 😀 Yeni çoğu zaman iyidir. MySQL için de bu böyle. Yeni sürümlerde yer alan karakter kodlaması birçok kullanıcıya sıkıntı getirse de, aslında çok güzel bir olay. Ayrıca yeni sürümlerdeki yeni fonksiyonlar MySQL sorgularına hız katıyor. Böylece eski sürümde bir sorgu sonrasında döngü kullanarak alt sorgular ile eriştiğiniz bir takım verileri, yeni sürümlerde döngü kullanmak zorunda kalmadan tek bir sorgu ile halledebildiğiniz durumlar oluyor. Bu, tabiki sistemin daha hızlı yüklenmesine destek oluyor. Özellikle MySQL AB 4.0 sürümüne destek vermeyi bıraktıktan sonra, wordpress üstündeki bu zorunluluk zaten gereksinim halini alıyor.

Etiketler

Benzer Yazılar

Yorumlar